Volkswagen Taos Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Is anybody else having weird software issues? I have had my display change from the redundant speed display with nothing on the sides, to showing just the speed, radio info, and trip info. When I try to hit view to change it back nothing happens. Turn the car off and back on and the correct display comes back on.

Occasionally the the radio gets stuck on the welcome screen until I restart as well.

I was on a 500 mile road trip and when I got back in after getting gas, the radio said I had no xm radio ID and no stations. Had to drive 300 miles in silence.

Hopefully it is just an update issue.
 

·
Registered
Joined
·
2 Posts
Hi there,
I utilize Apple Car Play almost always. I’ve had a few instances where it freezes or if I switch between radio sources, the screen will go blank. If you hold the power button on the touchscreen for about 45 seconds and then let go, it should restart the touchscreen - you’ll see the Volkswagen screen and then the system should start working again.
I took the car in for this and the rear traffic alert almost never working or waiting until after the car is already passed me before giving me an alert. They said that VW Is aware of the issue and that I will get a letter when an update is available to be installed.
 

·
Registered
Joined
·
124 Posts
This is an issue with the buggy (feels like beta) MIB3 system, not exclusive to the Taos. All models with this system experience issues and slow responses compared to the previous generation non-wireless car play systems.

If it’s any consolation, having used a Pacifica minivan with the Chrysler head unit with wireless car play for 18 days as a rental, the buggy MIB3 is still better. The Chrysler is even more buggy. Although the wider screen is better for carplay.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #4 ·
This is an issue with the buggy (feels like beta) MIB3 system, not exclusive to the Taos. All models with this system experience issues and slow responses compared to the previous generation non-wireless car play systems.

If it’s any consolation, having used a Pacifica minivan with the Chrysler head unit with wireless car play for 18 days as a rental, the buggy MIB3 is still better. The Chrysler is even more buggy. Although the wider screen is better for carplay.
So do you think this is also what impacts the speedometer display as well? Again this morning got in the car and the digital speed display came on but not the redundant circular display around it. I stopped at the store and when I restarted, it was there. I'm ok with some display bugs in a new system..I can't even use wireless car play because LG has not updated my phone to Android 11.
 

·
Registered
Joined
·
124 Posts
So do you think this is also what impacts the speedometer display as well? Again this morning got in the car and the digital speed display came on but not the redundant circular display around it. I stopped at the store and when I restarted, it was there. I'm ok with some display bugs in a new system..I can't even use wireless car play because LG has not updated my phone to Android 11.
Don’t know. But if there is option to factory reset and start over, try that. I was having some issues with my Jetta SEL Premium MIB3 and digital cockpit when new and restoring to factory seems to have worked for now. Booting up of all features is still slow, which is a disappointing throwback to the slow boot of the otherwise stellar system on my previous 2015 Toaureg.
 

·
Registered
Joined
·
124 Posts
Don’t know. But if there is option to factory reset and start over, try that. I was having some issues with my Jetta SEL Premium MIB3 and digital cockpit when new and restoring to factory seems to have worked for now. Booting up of all features is still slow, which is a disappointing throwback to the slow boot of the otherwise stellar system on my previous 2015 Toaureg.
I also find that if you turn the car off before the MIB3 is fully booted, then restart, all heck breaks loose. Then you have to either drive with a crippled system, or take the time to turn the car off and wait for the system to time out and restart, which most people don’t have time for.
 

·
Registered
Joined
·
8 Posts
My SEL started acting up the day after purchase. Driving down the road all the visual and noise alarms from all the IQ safety features starting going off and lighting up my dash and became non-functional....including the cruise control. Called VW and they said they were booked and couldn't get the car in for 3 weeks but drive it anyway cause everything else was functioning. Parked it in the garage till appointment where it sat all day waiting for VW corporate techs to call the mechanic and tell him what to do. They never called! And now I have to bring it in again tomorrow. After reading some of the other things going on with these vehicles I hope I didn't make a big mistake with this purchase.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #8 ·
I am really happy with the car and am confident the bugs will get worked out..we are kind of guinea pigs with a new model. I'm ok with software glitches but when it comes to safety features that is a different animal.
 
1 - 8 of 8 Posts
Top