Volkswagen Taos Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
46 Posts
Discussion Starter · #1 ·
Hi All,

I wanted to share the below info with those of you that might encounter this issue with CarPlay not working over Wifi. Sorry it's long winded but it was a complicated issue to resolve.

----

My car came with a free Verizon HotSpot Trial as part of my Carnet (car has it's own Cell phone antenna and eSIM).

Hotspot was working fine, nice way for friends to connect their devices to my car's internet if theirs wasn't working. Apple CarPlay over Wifi was working well also, which is a really nice convenience to not have to plug a USB cable in every time.

But after the 30 day trial ran out, I noticed that CarPlay would show on my car console, but if I tried to use anything like Maps, it would say something like "No Internet Connection". My Iphone would also be showing it has a wifi connection to the cars hotspot and I also couldn't load any websites from my phone.

At first I made the assumption that only Bluetooth was needed for CarPlay to work. Turns out not to be true. It's only needed for the initial setup, then Carplay needs the wifi since it sends a lot more data (basically streaming the whole visual interface of carplay to the car's console).

Then I made the assumption that the car's wifi hotspot is needed for CarPlay to work over wifi, and that if I didn't pay for the cell phone carrier's internet that CarPlay just wouldn't work. Also not true.

What I found out is Apple Carplay can work over its own special wifi connection to your iphone, or it can connect via the car's normal wifi hotspot. If it's the latter then you need to have some kind of data subscription with a cell phone carrier like Verizon or you'll run into the problem I mentioned above.

And it seems that if you use the Verizon trial as part of Carnet, then the Carplay configuration seems to rely on this hotspot connection for internet connectivity, without an easy way to break free from it after the trial ends.

After I followed the steps below I can now get CarPlay to work over it's special Wi-Fi connection without my iPhone trying to use internet through my cars hotspot (where I have no Verizon subscription or active trial).

Reset and remove my car from CarPlay
Without USB cable connected:
  1. While connected to cars hotspot Select “Forgot this Wi-Fi” for cars hotspot under Settings>WiFi in my iPhone.
  2. Then I selected “Forget this device” for my car under Settings>Bluetooth in my IPhone.
  3. Selected “Forget this car” under Settings>General>CarPlay in my IPhone
  4. Went to “mobile devices” in my car's settings and deleted my iPhone.
  5. I disabled the Wi-Fi hotspot under my car's settings.

Add CarPlay back
Without USB cable connected:
  1. I re-enabled the Wi-Fi hotspot in my car settings after a couple mins
  2. From my iPhone I went to Settings>General>CarPlay and re-added my car.
  3. My car console shows a message if I want to pair my iPhone which I said yes to. (Do this from the cars console first and then on iPhone if necessary but give it a few moments after pairing on the car)
  4. Press App on my car console and select my iPhone to connect.
If it's working properly you'll notice on the cars console when in CarPlay, at the top left it says LTE/5G instead of the Wi-Fi icon. And on the iPhone it says LTE/5G.

If it's still using the Car's normal WIFI hotspot, and internet in CarPlay is not working, at the top left in the cars console, you'll see a Wi-FI icon and on your Iphone it will also show a Wi-Fi icon. You may need to try the above steps again at this point, or just disconnect from the car's wifi on your iphone and use a USB cable to use CarPlay.

Note this was tested on an SEL AWD and my iPhone is a 13 pro with latest iOS (15.0.2).
 

·
Registered
Joined
·
1 Posts
Hi All,

I wanted to share the below info with those of you that might encounter this issue with CarPlay not working over Wifi. Sorry it's long winded but it was a complicated issue to resolve.

----

My car came with a free Verizon HotSpot Trial as part of my Carnet (car has it's own Cell phone antenna and eSIM).

Hotspot was working fine, nice way for friends to connect their devices to my car's internet if theirs wasn't working. Apple CarPlay over Wifi was working well also, which is a really nice convenience to not have to plug a USB cable in every time.

But after the 30 day trial ran out, I noticed that CarPlay would show on my car console, but if I tried to use anything like Maps, it would say something like "No Internet Connection". My Iphone would also be showing it has a wifi connection to the cars hotspot and I also couldn't load any websites from my phone.

At first I made the assumption that only Bluetooth was needed for CarPlay to work. Turns out not to be true. It's only needed for the initial setup, then Carplay needs the wifi since it sends a lot more data (basically streaming the whole visual interface of carplay to the car's console).

Then I made the assumption that the car's wifi hotspot is needed for CarPlay to work over wifi, and that if I didn't pay for the cell phone carrier's internet that CarPlay just wouldn't work. Also not true.

What I found out is Apple Carplay can work over its own special wifi connection to your iphone, or it can connect via the car's normal wifi hotspot. If it's the latter then you need to have some kind of data subscription with a cell phone carrier like Verizon or you'll run into the problem I mentioned above.

And it seems that if you use the Verizon trial as part of Carnet, then the Carplay configuration seems to rely on this hotspot connection for internet connectivity, without an easy way to break free from it after the trial ends.

After I followed the steps below I can now get CarPlay to work over it's special Wi-Fi connection without my iPhone trying to use internet through my cars hotspot (where I have no Verizon subscription or active trial).

Reset and remove my car from CarPlay
Without USB cable connected:
  1. While connected to cars hotspot Select “Forgot this Wi-Fi” for cars hotspot under Settings>WiFi in my iPhone.
  2. Then I selected “Forget this device” for my car under Settings>Bluetooth in my IPhone.
  3. Selected “Forget this car” under Settings>General>CarPlay in my IPhone
  4. Went to “mobile devices” in my car's settings and deleted my iPhone.
  5. I disabled the Wi-Fi hotspot under my car's settings.

Add CarPlay back
Without USB cable connected:
  1. I re-enabled the Wi-Fi hotspot in my car settings after a couple mins
  2. From my iPhone I went to Settings>General>CarPlay and re-added my car.
  3. My car console shows a message if I want to pair my iPhone which I said yes to. (Do this from the cars console first and then on iPhone if necessary but give it a few moments after pairing on the car)
  4. Press App on my car console and select my iPhone to connect.
If it's working properly you'll notice on the cars console when in CarPlay, at the top left it says LTE/5G instead of the Wi-Fi icon. And on the iPhone it says LTE/5G.

If it's still using the Car's normal WIFI hotspot, and internet in CarPlay is not working, at the top left in the cars console, you'll see a Wi-FI icon and on your Iphone it will also show a Wi-Fi icon. You may need to try the above steps again at this point, or just disconnect from the car's wifi on your iphone and use a USB cable to use CarPlay.

Note this was tested on an SEL AWD and my iPhone is a 13 pro with latest iOS (15.0.2).
THANK YOU!!! I have been struggling to figure this out for a few weeks, as soon as my trial WiFi period was up. Your detailed steps worked like a charm.
 
1 - 3 of 3 Posts
Top